Показано с 1 по 6 из 6

Тема: Завис ПЛК100. Прошу помощи.

  1. #1
    Пользователь Аватар для smk1635
    Регистрация
    06.09.2010
    Адрес
    Брянск
    Сообщений
    1,306

    По умолчанию Завис ПЛК100. Прошу помощи.

    Всем здравствуйте.
    Попросили модернизировать станок. Использовали ПЛК100 и ИП320. Проблема в следующем. ПЛК завис. Наглухо.
    Как объяснил наладчик. Он сделал загрузочный проект. Погонял станок. Заказчика результат не очень устроил. Он скорректировал. Залил заново программу (загрузочного проекта не делал). Потом еще раза 4 вносил изменения. И где то на 5 разе контроллер завис. К CoDeSys не подключится, выдает «ошибка связи». После нажатия «Ресет» через 2-3 секунды контроллер включается в работу. Связь с панелью есть, но на кнопки не реагирует. Светодиоды на входах на изменения реагируют. Если кто сталкивался с подобным, то подскажите выход. Или скиньте ссылку, если подобная тема уже обсуждалась на форуме. Сам к сожалению не нашел.

  2. #2
    Пользователь Аватар для smk1635
    Регистрация
    06.09.2010
    Адрес
    Брянск
    Сообщений
    1,306

    По умолчанию

    Так в том и проблема. Есть программа. Если бы не было. На ИП320 было бы "потеря связи". Да и индикатор "работа" на контроллере на горел бы. А так после нажатия ресета, контроллер опять в режим работа уходит. Только программу не отрабатывает. И подключится не дает.

  3. #3

    По умолчанию

    Вроде бы у вас контроллер попадает в вечный цикл и постоянно сбрасывается по вачдогу. Насколько я помню, для подключения из кодесис к контроллеру, "работающему" в таком режиме, нужно выключить контроллер, нажать кнопку "ресет", и, удерживая её в нажатом состоянии, подать на контроллер питание. Тогда он не начнёт исполнение программы, а будет ожидать подключения к себе.
    Железяка должна быть такой: нажал кнопку — работает

  4. #4
    Пользователь Аватар для smk1635
    Регистрация
    06.09.2010
    Адрес
    Брянск
    Сообщений
    1,306

    По умолчанию

    Да, удерживать ресет с отключением питания не пробовал. В понедельник попробую.
    Вот интересно, а из-за чего так могло случится. Программу проверил за наладчиком, вроде все нормально.

  5. #5

    По умолчанию

    Скорее всего наладчик не затирал старый код при записи нового.
    Необходимо при установке связи сделать сброс заводской из меню онлайн. А так же очистить все.
    Ну и перекомпилируйте проект целиком (F11)

  6. #6
    Пользователь Аватар для smk1635
    Регистрация
    06.09.2010
    Адрес
    Брянск
    Сообщений
    1,306

    По умолчанию

    Вопрос решён. Востановить связь действительно получилось через ресет и включение питания, как и советовали. После заводского сброса программа заработала.
    Всем откликнувшимся большое спасибо.

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •