Показано с 1 по 9 из 9

Тема: отправка Sms через модем пм01

  1. #1

    По умолчанию отправка Sms через модем пм01

    Столкнулся с такой проблемой - пробую отправлять Sms через модем пм01 - просто гипертерминалом посылаю ат-команды. Отправляю в текстовом режиме (at+cmgf=1) - и после Ctrl+z чаще всего получаю "+cms Error: 515, вместо сообщения о нормальной отправке. Ошибка вылезает более чем на 50% отправленных **** остальные уходят правильно.
    Причем даже если вылезла ошибка, Sms может все-таки дойти.
    Что бы это могло быть?

    И второе - в результате такого поведения модема пример с диска от плк100 работает нестабильно - Sms не уходят, а программа считает, что все хорошо - т.к. программа не проверяет ответ модема после отправки Sms. Нельзя ли как-то доработать пример, чтоб сигнализировал об ошибке?

  2. #2

    По умолчанию

    здравствуйте, михаил.

    что у вас за модем? какие сетевые настройки? можете назвать серийный номер?
    если не сложно сделайте и выложите лог обмена пк с модемом во время отправки.

  3. #3

    По умолчанию

    Модем ПМ01-220.АВ зав.№ 31609100502281651
    Подключен к компу в COM1 - 9600, 8бит, 1 стоп, нет четности - т.е. заводские настройки модема. А насчет лога... что-то типа вот такого:
    AT+CMGF=1
    OK
    AT+CMGS="+7903(номер телефона)"
    >test message
    +CMS ERROR:515

    И еще неприятный момент - после подачи питания очень долго ищет сеть - минут 10..30.
    Потом попробовал подключить модем Siemens MC35i с той же симкой - подключается мгновенно (секунды), смс-ки теми же командами отправляет правильно.
    Последний раз редактировалось Мамонов Михаил; 31.05.2010 в 21:34.

  4. #4

    По умолчанию

    Кстати, вот тут есть чудный пример работы с модемом - http://www.owen.ru/forum/showpost.ph...1&postcount=58
    он постоянно опрашивает модем на предмет подключения к сети. И вот уже 2 часа наблюдаю +CREG 0,0 - почему так?
    Соответственно, модем мигает "нет сети"...
    Иногда кратковременно проскакивает +CREG 0,2 - и потом опять нули.
    На всякий случай проверил - вынул симку из модема и сунул в телефон - есть сеть, т.е. симка и контракт живые. А как бы проверить - сам модем то живой?
    Последний раз редактировалось Мамонов Михаил; 01.06.2010 в 11:18.

  5. #5

    По умолчанию

    Есть команда at+csq, выдает уровень GSM сигнала.

  6. #6

    По умолчанию

    AT+CSQ выдает +CSQ: 99,99
    по описанию - 99 это "not known or not detectable"
    Похоже, модем сеть не видит вообще. Сегодня не смог подключиться ни разу. Может, он аппаратно неисправен? Можно как-то проверить? Или лучше его в сервис отправить?

    Подключил Siemens MC35i с той же симкой - показывает +CSQ: 18,99

  7. #7

    По умолчанию

    1) есть вероятность, что сим карта отходит от разъема и соответственно связи нет.
    2) проверьте антенну

    P.s. честно говоря, сам недавно на такой модем наткнулся.

  8. #8

    По умолчанию

    антенну другую попробовал - результат тот же.. пробовал разными симками - тоже не помогает. сеть не находит вообще. так что в сервис, завтра отправлю

  9. #9

    По умолчанию

    модем заменили по гарантии. новый пока работает без проблем - отправил штук 50 смс - все дошли.
    сеть находит секунд за 10, уровень сигнала по At+csq - от 7 до 15

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •