Страница 1 из 2 12 ПоследняяПоследняя
Показано с 1 по 10 из 18

Тема: входы глючат

  1. #1

    По умолчанию входы глючат

    возникла проблема - при замыкании дискретных входов(кроме первого), возникает ошибка
    контроллер - плк150-U-L прошивка 2.01.1
    прилагаю проект - bad_inputs.zip

    как с этим бороться?

    bad_inputs.jpg
    Последний раз редактировалось Ушаков Николай; 20.06.2007 в 19:55.

  2. #2
    Пользователь
    Регистрация
    05.05.2007
    Адрес
    Барнаул->Москва
    Сообщений
    140

    По умолчанию

    Николай, была такая же проблема с ПЛК 100. Так и не понял - как решилась, но делал следующее: снял галочку проверки перехлестывания памяти, откомпилировал, залил.... затем обратно поставил, опять откомпилил и залил... Галочка находится в PLC конфигураторе - в свойствах ПЛК. Их там три - нужная - средняя "Chech for...."

  3. #3

    По умолчанию

    да, изредка среда разработки переходит в странное состояние.
    описанный метод решения помогает.

  4. #4
    Пользователь
    Регистрация
    31.05.2007
    Адрес
    Санкт-Петербург
    Сообщений
    35

    По умолчанию

    Цитата Сообщение от филоненко владислав Посмотреть сообщение
    да, изредка среда разработки переходит в странное состояние.
    описанный метод решения помогает.
    м-да, оригинально. а чья вина? плк или кодесис?

  5. #5

    По умолчанию

    неа, галочка не помогла - все то же самое.

  6. #6

    По умолчанию

    среда разработки переходит в странное состояние, на др. ПЛК будет тоже самое.

    Если галочка в конфигурации не помогает, то надо в Project->Options->Build->Check overlaped areas

  7. #7

    По умолчанию

    Project -> Options -> Build группа Check automatically галочка Overlapping memory areas - не помогло

    пробовал на двух контроллерах, менял версию на предыдущую с форматированием, пробовал то же на другом компе - не проходит

  8. #8

    По умолчанию

    CodeSys удалил и снова установил - вроде старые настройки среды должны были сброситься, но не тут то было...

    и светодиоды уже все протирал, ну ничего не помогает...

  9. #9

    По умолчанию

    Цитата Сообщение от Ушаков Николай Посмотреть сообщение
    CodeSys удалил и снова установил - вроде старые настройки среды должны были сброситься, но не тут то было...

    и светодиоды уже все протирал, ну ничего не помогает...
    А какая у вас версия среды разработки? Самая свежая - 2.3.8.1

  10. #10

Страница 1 из 2 12 ПоследняяПоследняя

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •