Страница 2 из 3 ПерваяПервая 123 ПоследняяПоследняя
Показано с 11 по 20 из 28

Тема: Нет обмена по модбасу со сторонними устройствами.

  1. #11

  2. #12

    По умолчанию

    Обмен заработал. Не пойму как. Спасибо всем кто участвовал.

  3. #13

  4. #14

    По умолчанию Прога рабочая и нет

    Зазиповал два архива.
    Вложения Вложения

  5. #15

    По умолчанию

    Теперь я поднял канал с ZT. Но во всех регистрах я вижу нолики, чёрного цвета. Послал в их поддержку вопрос , надеюсь что нибудь подскажут. А может мой порт не красивые биты шлёт?

    запрос.jpg
    Последний раз редактировалось Serrk; 27.12.2020 в 11:54.

  6. #16
    Супер Модератор Аватар для Евгений Кислов
    Регистрация
    27.01.2015
    Адрес
    Москва
    Сообщений
    7,285

    По умолчанию

    В первом проекте в Modbus_Slave_COM_Port для параметра Всегда обновлять переменные не установлено значение Вкл. 2.
    Так что ничего странного в наблюдаемой ситуации нет.

    Гораздо интереснее, какие манипуляции привели к налаживанию обмена с ICP DAS.

  7. #17
    Супер Модератор Аватар для Евгений Кислов
    Регистрация
    27.01.2015
    Адрес
    Москва
    Сообщений
    7,285

    По умолчанию

    Цитата Сообщение от Serrk Посмотреть сообщение
    Теперь я поднял канал с ZT. Но во всех регистрах я вижу нолики, чёрного цвета. Послал в их поддержку вопрос , надеюсь что нибудь подскажут. А может мой порт не красивые биты шлёт?

    запрос.jpg
    Вероятно, дело опять в той настройке, о которой я писал выше:
    https://owen.ru/forum/showthread.php...l=1#post343792

  8. #18

    По умолчанию Почему заработало?

    Я создал новый проект в котором создал канал модбас. Подключил к нему модуль мв 110 224 8а. Увидал на модуле моргающую лампочку " обмен по порту" решил, что всё в порядке. Но не смотря на мигающую лампочку обмен не происходил.не раб мв.jpg . Мне нужно было посмотреть ,что за переменные идут (подвела самоуверенность). Я подсоединил к этому каналу , на теже провода ZT 2570 и увидел отсутствие обмена. Когда увидел отсутствие обмена с МВ 110, удивился. Открыл старый проект с работающим обменом, скопировал от туда полностью порт, вставил в новый проект, и обмен пошёл.
    МВ ок.jpg

  9. #19

  10. #20

    По умолчанию

    Да нет нолики чёрные и настройку попереключал . И настройки канала ZT пробовал сдвиг 0 ,30000, 30001 функция 4 и 3 (чтение)

Страница 2 из 3 ПерваяПервая 123 ПоследняяПоследняя

Похожие темы

  1. CODESYS V3.5. Настройка обмена с другими устройствами (Modbus, ОВЕН, OPC и др.)
    от Евгений Кислов в разделе ПЛК (среда программирования CODESYS V3.5)
    Ответов: 674
    Последнее сообщение: Вчера, 13:43
  2. обрывы соединения по модбасу
    от Mesoma в разделе СПК1хх
    Ответов: 2
    Последнее сообщение: 26.04.2019, 07:53
  3. Универсальная функция для обмена с устройствами OwenIO и всеми любимый LabView.
    от Алексей Крагель в разделе Помощь Разработчикам
    Ответов: 0
    Последнее сообщение: 30.05.2014, 14:38
  4. мва 8 по модбасу-время для пид?
    от kait-leon в разделе ПЛК1хх
    Ответов: 1
    Последнее сообщение: 13.11.2010, 23:46
  5. Связь с устройствами по Modbus
    от Mayk в разделе ПЛК1хх
    Ответов: 5
    Последнее сообщение: 02.09.2010, 17:49

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •