Страница 2 из 5 ПерваяПервая 1234 ... ПоследняяПоследняя
Показано с 11 по 20 из 47

Тема: МУ210-501 после длительного простоя предположительно не выходит из безопасного режима

  1. #11

    По умолчанию

    Добрый день, подобная ситуация с МУ210-403 и МВ210-202. Модули включены в сеть, которая упала. Модули ушли в безопасный режим, но после налаживания сети не выходят из безопасного режима, до тех пор пока их не перезагрузишь по питанию. До них пинга даже нет. Стоят моргают красными индикаторами, выкл/вкл питание - связь тут же налаживается и всё работает и так до следующего сетевого эксцесса. IP-адреса прописаны вручную.
    Прошивка 0.15.11, посмотрел в этой прошивке вроде как пофиксили этот баг, тем не менее проблема существует.
    Подскажите, можно ли что-то сделать? Или выхода пока нет и придётся тупо питание модулей ресетить?

  2. #12

    По умолчанию

    Добрый день.
    У Вас ситуация иная, так как модули не отвечают по Ethernet. Вероятно ситуация похожа на эту: https://owen.ru/forum/showthread.php...l=1#post338391
    Какая нагрузка подключена к модулю МУ210-403?
    Инженер по продуктам «ПЛК и модули»
    e-mail: i.masterenko@owen.ru | skype: i.masterenko_owen

  3. #13

    По умолчанию

    Нагрузка: 3 шт. примерно 15-20-Ватных вентилятора на 220в подключенные кабелями 10-30м в одном месте, и 4 парафиновые термоголовки в другом месте мощностью 2Вт 220В, но нюанс, всё-таки в том, что "зависают" ещё и мв210-202. При этом 100% повторяемость возникала каждый раз, когда отказывался работать коммутатор и прибор выпадал в аварийный режим даже без коммутации нагрузки.

  4. #14

    По умолчанию

    Подскажите пожалуйста, если во время "зависания" убрать из цепочки 403-й модуль, то 202-й работает?
    Ведущий инженер проектов
    Линейки шлюзов сетевых Пх210
    Линейки модулей ввода/вывода Мх210

  5. #15

    По умолчанию

    Цитата Сообщение от e.filatov Посмотреть сообщение
    Подскажите пожалуйста, если во время "зависания" убрать из цепочки 403-й модуль, то 202-й работает?
    пока не могу такого сказать доступ к модулям будет примерно в течение недели

  6. #16

    По умолчанию

    В общем, перечитал все сообщения из той темы, вероятно да, ситуация схожая и вероятно ищем проблему возможно не там. Фотографии щита предоставить не могу, но есть щит, где стоят мв210-202, мв210-403, мв210-101, бок о бок на одной рейке.
    403-й управляет тремя лампочками и четырьмя парафиновыми термоголовками, всё 220в, а также одним шнайдеровским контактором. НО! нюанс в том, что это всё стоит в щите в бане, это часть умного дома, и это всё добро там попросту бездействует, потому что в доме никто не живёт и это всё стоит там и никто ничего не трогает. Даже парафиновые головки стоят незадействованные. т.е. 403 тупо висит на связи с выключенными выходами и ждёт команды на включение. И тут происходит какой-то сетевой коллапс. Мне коллега пишет, что отвалились камеры на доме. При этом никто в дом не приходил и ничего там не делал. Прошла пара дней и т.к. такие прецеденты были, решили заменить коммутатор в этом щите. Товарищ монтажник всё благополучно заменил позвонил мне и говорит, что красные лампочки также моргают и клавиши в бане не работают также как и свет, он передёрнул автомат питания модулей и красные лампочки не загорелись и всё заработало. Так было ещё раз. Один в один.
    К чему я это всё написал, к тому, что в том щите ничего не включалось совсем, но модули отвалились и не подвалились обратно пока их не перезапустили по питанию.

  7. #17

    По умолчанию

    Какая длина линии Ethernet от коммутатора до модулей? Не проходит ли она рядом с силовым оборудованием?
    Если длина линии Ethernet между коммутатором и модулями небольшая , то можно попробовать подключить модули не цепочкой, а звездой.
    Какие ещё устройства подключены к коммутатору? Не теряется ли связь с ними?
    Раз управление пока не требуется, можно откинуть клеммник с нагрузкой, чтобы убедиться, что дело на стороне Ethernet.
    Инженер по продуктам «ПЛК и модули»
    e-mail: i.masterenko@owen.ru | skype: i.masterenko_owen

  8. #18

    По умолчанию

    Между коммутатором и модулями длина линии примерно 30 см. Точно не помню, возможно модули и подключены звездой. Линия проходит рядом с силовым оборудованием (в 10 см+-), но как такового силового оборудования нет, самое "силовое" оборудование - это светодиодный светильник на 7 Вт в пяти метрах от щита. Связь с устройствами, подключенными к коммутатору терялась, видеокамеры не работали, поэтому и заменили коммутатор. Смысла откидывать клеммник нет, оборудование не задействовано самопроизвольное включение выходов я исключаю. Буду на месте удостоверюсь, что модули подключены отдельно звездой, а не цепочкой, вообще, я так и стараюсь делать, подключать звездой, но там стеснённое пространство мог подключить цепочкой.

    Сейчас припоминаю ещё один подобный случай, но уже в другом щите. Там стоят два 403 и два 202 и один ПЛК110 они все подключены звездой к одному коммутатору, что звездой подключены - это 100%, и по каким-то неясным причинам у меня зависла эта самая звезда т.е. не пинговались ни плк ни модули при этом остальная сеть снаружи коммутатора пинговалась, я перезагрузил коммутатор и вышли на связь плк и какие-то 2 модуля, уже не помню какие, а другие два также моргали индикатором безопасного режима, пока я не перезагрузил их по питанию. В том щите такой случай был единожды за год, хотя там находятся и контакторы и промежуточные реле одной рейкой ниже. Сам коммутатор стоит в том же щите, от коммутатора до модулей и плк 20-40 см кабеля, проложено всё вместе с силовыми проводами рядом.

    Возможно мой подход к решению проблемы не совсем правильный ведь надо устранять причину, а не следствие, но может быть есть возможность зашить в прошивку цикличный рестарт ethernet-интерфейса у модулей при отсутствии связи и переходе в безопасный режим, рестарт интерфейса по типу, как происходит при ресете по питанию? Там же есть какие-то коммутационные возможности по интерфейсам в модулях или нет? Понятно, что причина этим не устранится, но работоспособность в некоторых случаях сохранится и не надо будет вручную ресетить модули в поисках истины, а вы уже там самостоятельно попробуете найти саму причину и устранить её.

    И мой вопрос касался именно этого, и я так понял сейчас этой функции нет, поэтому исключительно для себя я пока вижу банально тупой способ решения этой проблемы, мне безопасное состояние не требуется, поэтому я просто повешу на какой-нибудь из выходов реле, которое будет срабатывать при переходе в безопасное состояние и рубить питание модулей и так циклично пока не появится связь. Потому что ездить так самому или просить кого-то ресетить вручную, ну не есть гуд.

  9. #19

    По умолчанию

    Немного новостей, модули подцеплены цепочкой были в том месте, про которое была речь.

    Сегодня неоднократно перезаливал программу в контроллер, заливка программы сопровождается полным обесточиванием всего дома, вследствие чего отключаются контакторы и реле причем разом, и в один "прекрасный" момент у меня просто отвалилась часть сети, причем отвалилась она на коммутаторах. т.е. банально восьмипортовые свитчи перестали пропускать пакеты пока я их не ребутнул последовательно по одному в каждом щите.

    Тем не менее в одном щите уже как дня два или 3 висел в аварийном режиме один единственный 403 модуль, а другие модули подключенные к этому свитчу работали как ни в чём не бывало. ребутнул модуль по питанию и он тут же появился в сети.

  10. #20

    По умолчанию

    Цитата Сообщение от e.filatov Посмотреть сообщение
    Подскажите пожалуйста, если во время "зависания" убрать из цепочки 403-й модуль, то 202-й работает?
    Это уже походит на какой-то дневник, но тем не менее. В общем смоделировал постоянно повторяющуюся ситуацию по зависанию модуля. Происходит она после запуска контактора шнайдер, находящегося на одной и той же дин рейке с модулями.

    Зависает один 403, при этом он полностью вешает сеть на коммутаторе к которому подцеплен, что даже камеры перестают работать. Если отключить 403 от коммутатора то сеть поднимается, работа камер восстанавливается.
    Если не разъединяя цепочку, которая у меня начинается с 403-го модуля, отключить от коммутатора и подключить её с другого конца со стороны мв210-101, то 101 и 202 модули ввода начинают работать, а 403 также висит в безопасном режиме и ни на что не реагирует.

Страница 2 из 5 ПерваяПервая 1234 ... ПоследняяПоследняя

Похожие темы

  1. Ответов: 13
    Последнее сообщение: 27.12.2019, 14:47
  2. Ответов: 4
    Последнее сообщение: 16.02.2018, 14:40
  3. Ответов: 6
    Последнее сообщение: 23.05.2015, 23:29
  4. Ответов: 13
    Последнее сообщение: 20.08.2011, 00:31
  5. Ответов: 2
    Последнее сообщение: 03.11.2010, 13:32

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •