Показано с 1 по 8 из 8

Тема: Проблема с ПЛК-73

  1. #1

    По умолчанию Проблема с ПЛК-73

    Господа, проблема в следующем: есть 2шт. ПЛК-73 ККККРРРР-L, работали на объектах года 4. В одно прекрасное утро перестал стартовать один из них. Назовем его №1. При подаче питания на экране пустота, затем раздается звук, как обычно при включении. Далее ничего не происходит. При нажатии на кнопки тоже никакой реакции. Думал, что проблема с прошивкой. Хотел перепрошить, для чего скачал последнюю прошивку с сайта. Программа прошивки не обнаружила версии текущей прошивки, но прошивка на скачанную версию прошла вполне себе штатно. После окончания прошивки ПЛК перезагрузился, но ничего не изменилось. Также звук при включении и далее нет реакции на кнопки и пустой экран. При попытке установить связь из CODESYS он пишет, что целевая платформа не соответствует ПЛК. Хотя прошивал именно для ПЛК-73 L. Попытка выбора другой платформы (ПЛК-73 М) тоже результата не принесла. ПЛК был заменен на новый. Через некоторое время перестал нормально функционировать другой аналогичный ПЛК на другом объекте. Назовем его №2. Ненормальность заключается в неработоспособности релейных выходов. Хотя транзисторные функционируют нормально. Что самое интересное, что при записи в них значения 1 (что должно соответствовать включенному состоянию реле) реле щелкает, но как показывает мультиметр, оно кратковременно включается, на доли секунды. Причем это происходит одинаково на всех 4-х выходах. Запись любого значения, отличного от 0 приводит к однократному кратковременному включению соответствующего реле. Во всём остальном ПЛК функционирует нормально, кроме 4-х релейных выходов. Пробовал и его тоже перепрошить. Также прошивка прошла нормально. Причем, в отличии от №1 программа прошивки смогла опознать текущую прошивку. После перепрошивки в его работе также ничего не изменилось. Есть ли какие варианты реанимации данных ПЛК, кроме обращения в сервис?

  2. #2
    Пользователь
    Регистрация
    11.01.2009
    Адрес
    Кострома
    Сообщений
    3,216

    По умолчанию

    В ПЛК 73 для включения реле нужно записать в его регистр 1000, а не 1.
    По остальному- в ремонт.

  3. #3

    По умолчанию

    Записать надо 1, с плавающей точкой.

  4. #4
    Пользователь
    Регистрация
    31.07.2013
    Адрес
    Аркаим
    Сообщений
    914

    По умолчанию

    ПЛК-73 ККККРРРР-L, работали на объектах года 4.
    реле щелкает, но как показывает мультиметр, оно кратковременно включается, на доли секунды.
    Питание 230В, от встроенного БП? Очень высокая вероятность того, что посохли конденсаторы фильтра питания на "холодной" стороне встроенного БП.
    Есть ли какие варианты реанимации данных ПЛК, кроме обращения в сервис?
    Есть, если знаете с какой стороны браться за паяльник.

  5. #5

    По умолчанию

    Конденсаторы проверил в первую очередь. Проследил по деталькам что управляет дискретными выходами. Дошел до сдвигового регистра. У него 8 выходов. 4 из них управляют транзисторными выходами и 4 релейными. Пробовал соединить 2 выхода этого регистра: выход управляющий транзисторным выходом с выходом, управляющим релейным. Реле начинает отрабатывать значение, записанное в соответствующий транзисторный выход (для наглядности записывал значение 0,5 и 1). Очевидно, что блок питания работает в штатном режиме, как и вся цепочка от сдвигового регистра до непосредственно реле.

  6. #6
    Пользователь
    Регистрация
    31.07.2013
    Адрес
    Аркаим
    Сообщений
    914

    По умолчанию

    Конденсаторы проверил в первую очередь.
    ESR у них мерили?

  7. #7

    По умолчанию

    Нет, просто поменял на новые.

  8. #8

    По умолчанию

    Есть проблема: на котле КВГ стоит ПЛК 73 ККККРРРР-М. И ПЛК потерял датчик температуры: " Тводы:неисправность". Датчик проверил- исправен. Решил переподключить датчик на другой канал. Но в CODESYS в онлайн режиме подключения к ПЛК во все глобальные переменные по 8-ми аналоговым каналам записано одно постоянное значение = -4,25353е+037. и это значение не меняется ни от типа датчика ни от подключенной ко входу ТСМ, ни от калибратора 0-1 В. в чем может быть причина? есть идеи?

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •