Страница 1 из 2 12 ПоследняяПоследняя
Показано с 1 по 10 из 13

Тема: ОВЕН МВА8+АС4

  1. #1

    По умолчанию ОВЕН МВА8+АС4

    Подключил ОВЕН МВА8+АС4 к ПК.
    с помощью Конфигуратор МВА8 все подключается, настраивается и показания датчиков отображаются.
    в настройках устройства указал протокол Modbus-RTU
    и пробую считать показания с помощью утилиты modpullполучается где-то так:
    C:\win32>modpoll.exe -m rtu -a 16 -r 1 -c 6 -t 3:hex -b 9600 COM2

    modpoll 2.9 - FieldTalk(tm) Modbus(R) Polling Utility
    Copyright (c) 2002-2010 proconX Pty Ltd
    Visit http://www.modbusdriver.com for Modbus libraries and tools.

    Protocol configuration: Modbus RTU
    Slave configuration...: Address = 16, start reference = 1, count = 6
    Communication.........: COM2, 9600, 8, 1, even, t/o 1.00 s
    Data type.............: 16-bit register (hex), input register table

    Polling slave (Ctrl-C to stop) ...
    Reply time-out!
    Polling slave (Ctrl-C to stop) ...
    Reply time-out!


    с помощью сниффера rs232 посмотрел на обмен данными
    modpull чесно шлет "10 04 00 00 00 06 73 49"

    подскажите плз. что я не так делаю

    заранее благодарен!

  2. #2

    По умолчанию

    Да, после смены протокола устройство выключал-включал...

  3. #3

    По умолчанию

    Перемычка заводских настроек снята?
    Кирилл Валюнин
    Компания ОВЕН
    Директор по развитию ассортимента

    skype: valunin_owen
    e-mail:k.valyunin@owen.ru

  4. #4

    По умолчанию

    Да, перемычка Х1 снята.

  5. #5

    По умолчанию

    Перевели протокол, сняли питание, сняли перемычку (если она стояла).
    После этого связывайтесь по ModBuS-все должно заработать.
    Запрос от программы в сниффере Вы видете, а ответ модуля?
    Кирилл Валюнин
    Компания ОВЕН
    Директор по развитию ассортимента

    skype: valunin_owen
    e-mail:k.valyunin@owen.ru

  6. #6

    По умолчанию

    Перевел протокол.
    Снял питание, проверил перемычку - снята,
    Включил питание.
    Включил сниффер, смотрю:
    1. Утилита "Конфигуратор МВА8" посылает запросы и получает ответы.
    2. утилита modpoll посылает запросы но не получает ответов.
    я обратил внимание на то что "Конфигуратор МВА8" все-равно общается по протоколу ОВЕН не смотря на то что выставлен протокол Modbus-RTU
    и еще эти утилиты по разному работают с RTS,DTR

  7. #7

    По умолчанию

    а зачем после включения питания Вы включаете конфигуратор?
    Конфигуратор только по ОВЕНу работает. Поменяли протокол, сбросили питание, далее модполл.
    Кирилл Валюнин
    Компания ОВЕН
    Директор по развитию ассортимента

    skype: valunin_owen
    e-mail:k.valyunin@owen.ru

  8. #8

    По умолчанию

    Включаю конфигуратор для того чтобы убедится возможности подключения в данный момент.
    Попробовал схему без запуска конфигуратора - аналогично.

  9. #9

    По умолчанию

    Тогда еще раз проверьте настройки программы, которую Вы используете для формирования запросов. Четность в модулей even у Вас стоит?
    Кирилл Валюнин
    Компания ОВЕН
    Директор по развитию ассортимента

    skype: valunin_owen
    e-mail:k.valyunin@owen.ru

  10. #10

    По умолчанию

    хз, проверил еще вроде все ок.
    с четностью все ок, я просто пробовал разные варианты конфигурации.
    вопрос: нет ли у вас своей реализации протокола ModBus или можно ли посмотреть на то как реализована низкоуровневая работа с последовательным портом в вашей библиотеке овен.
    мне кажется что-то там с преобразователем /который полуавтоматический/ не так, в плане работы с RTS, DTR

Страница 1 из 2 12 ПоследняяПоследняя

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •