Показано с 1 по 6 из 6

Тема: Проблемы с чтением данных из Овен МВ110-8AC

  1. #1

    По умолчанию Проблемы с чтением данных из Овен МВ110-8AC

    Доброго времени суток, уважаемые форумчане!

    Подключаю к модулю Овен МВ110-8AC датчики типа 0-10В.
    Выбрал соответствующий тип датчика для входов в конфигураторе. И тут пошли проблемы.
    Максимальное и минимальное значение от 0 до 28 соответственно.
    Подключил по схеме (датчик 3-х проводный со своим питанием).
    НА вход приходит 3 - 5В.
    Почему то он мне постоянно пишет измеренное значение 10. изменяются только сотые, хотя должен показывать 8,4 и 14 соответственно

    Что я делаю не так?

    Далее хочу считывать значения датчика через RS485 с помощью преобразователя и ПК.
    Какие номера регистров для Вход №1?
    Нашел вот такие данные:
    Овен МВ110-8AC
    Вход Тип регистра номер регистра тип данных комментарий
    1 HR(4x) \ IR(3x) 64 word (int16) Измеренное значение

    Однако ничего не могу считать через Modbus Poll пишет illegaldata

    Буду очень признателен за Ваши подсказки

  2. #2

    По умолчанию

    Я вот тут тоже вопрос задал по поводу чтения данных с модуля ввода. Походу читать можно только значение одного регистра данных за один запрос. В ModbusPoll выставьте Setup / Read/Write Definition значение Qantity = 1. Данные увидите.

  3. #3
    Пользователь Аватар для capzap
    Регистрация
    25.02.2011
    Адрес
    Киров
    Сообщений
    9,678

    По умолчанию

    оба пробовали читать документацию?
    Изображения Изображения
    • Тип файла: png owen.png (122.4 Кб, Просмотров: 46)
    Bad programmers worry about the code. Good programmers worry about data structures and their relationships

    среди успешных людей я не встречала нытиков
    Барбара Коркоран

  4. #4

    По умолчанию

    Не поверите, пробовали Только прибор возвращает Illegal Data Value при попытке чтения более 1-го регистра. И у МВ110-8АС вроде как все доступные регистры ModBus только на чтение. В них ничего не пишется.

  5. #5

    По умолчанию

    Это я знаю прекрасно, в том-то и беда. Вот почему "лыжи не едут"?
    Без имени-1.jpg
    Без имени-2.jpg

  6. #6

    По умолчанию

    Съедаю свою шляпу.
    Я пытался его опрашивать как МВ110-хх.8А, а он 8АС и там все по другому. Спасибо, теперь все работает.

Похожие темы

  1. ПЛК-74М Проблемы с выводом данных на экран.
    от Кирилл М. в разделе ПЛК63/73
    Ответов: 2
    Последнее сообщение: 18.01.2019, 20:50
  2. Modbus TCP. Проблемы с чтением из Holding регистров.
    от yulya.aniskina2010 в разделе ПЛК3хх
    Ответов: 3
    Последнее сообщение: 10.10.2015, 16:08
  3. Проблема с чтением блока МВ110-32ДН
    от hawk в разделе ПЛК1хх
    Ответов: 8
    Последнее сообщение: 21.01.2014, 22:18
  4. Ответов: 4
    Последнее сообщение: 21.04.2010, 13:38
  5. проблемы с получением данных от трм-138
    от gold в разделе Эксплуатация
    Ответов: 5
    Последнее сообщение: 19.05.2009, 15:13

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •