Показано с 1 по 3 из 3

Тема: Некорректное отображение в "Визуализации"

  1. #1

    По умолчанию Некорректное отображение в "Визуализации"

    Здравствуйте!

    Подскажите, пожалуйста, почему так может быть - когда я в модуле "Контроллеры" меняю значение булевой переменной на входе, выходное значение меняется (что логично - скрипт так и работает), но при этом в модуле "Визуализация" выходное значение меняется только если булевая переменная меняется с false на true (false - значение по умолчанию). При этом визуализация меняет значение булевой переменной, но не меняет результирующее значение скрипта...

    Как удалось выяснить —*скрипт не принимает условные операторы. Ни*if, ни*Case. В случае, если вывод значения не зависит от каких-либо условий и просто вычисляется по формуле, визуализация работает корректно. Подскажите, пожалуйста, можно ли каким-либо образом присваивать вещественной*переменной одно из 2 значений, не прибегая к скрипту? И почему всё-таки модуль «Контроллеры» работает корректно, а «Визуализация» —*нет?

    Заранее спасибо за ответ!
    Последний раз редактировалось Анастасия Г.; 29.10.2019 в 21:09.

  2. #2

    По умолчанию

    Цитата Сообщение от Анастасия Г. Посмотреть сообщение
    Здравствуйте!

    Подскажите, пожалуйста, почему так может быть - когда я в модуле "Контроллеры" меняю значение булевой переменной на входе, выходное значение меняется (что логично - скрипт так и работает), но при этом в модуле "Визуализация" выходное значение меняется только если булевая переменная меняется с false на true (false - значение по умолчанию). При этом визуализация меняет значение булевой переменной, но не меняет результирующее значение скрипта...

    Как удалось выяснить —*скрипт не принимает условные операторы. Ни*if, ни*Case. В случае, если вывод значения не зависит от каких-либо условий и просто вычисляется по формуле, визуализация работает корректно. Подскажите, пожалуйста, можно ли каким-либо образом присваивать вещественной*переменной одно из 2 значений, не прибегая к скрипту? И почему всё-таки модуль «Контроллеры» работает корректно, а «Визуализация» —*нет?

    Заранее спасибо за ответ!
    Есть некоторые особенности в настройке виртуального контроллера типа WKlogic. Нужно изменить в карте адресов контроллера тип передачи параметров, затем выставить передавать "по изменению". Открыть карту адресов кнопка "F8". 2019-10-31_112349.png
    Последний раз редактировалось Сергей Сисейкин; 31.10.2019 в 11:26.
    С уважением Сисейкин Сергей
    Инженер направления "Энергетика"
    http://energy.owen.ru

  3. #3

    По умолчанию

    Большое спасибо! Теперь всё работает!

Похожие темы

  1. Ответов: 13
    Последнее сообщение: 18.06.2018, 09:01
  2. Ответов: 16
    Последнее сообщение: 15.02.2017, 11:39
  3. Ответов: 4
    Последнее сообщение: 20.08.2015, 10:31
  4. Ответов: 49
    Последнее сообщение: 06.08.2015, 14:38
  5. Ответов: 20
    Последнее сообщение: 15.04.2015, 11:02

Метки этой темы

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •