Показано с 1 по 8 из 8

Тема: Линия rs485 и ОВЕН АС4

  1. #1

    По умолчанию Линия rs485 и ОВЕН АС4

    Добрый день,
    Прощу помощи, а даже больше пояснений.
    Ситуация такая, есть построенная давным давно линия rs485, на ней «висят» около 30 приборов. Линия построена неправильно, т.е. с большим кол-вом ответвлений.(рис.1)

    При попытке опроса приборов через преобразователь Ethernet-RS485, на запросы постоянно прилетают «нули», резисторы 120Ом на концах линии проблему не решают, но как только в начале линии я параллельно подключаю преобразователь АС4(с DIP переключателем в положение 100Ом) и подаю на него питания через USB(рис.2), то сразу начинается опрос через Ethernet-RS485 без ошибок. Отключив питания с АС4, но не снимая с линия, опять в ответ нули.

    Как это можно объяснить? Что происходит при падаче питания на АС4?
    Колхозным методом я конечно могу оставить в начале линии AC4 воткнутым в usb-блок питания , но мне кажется это не правильный выход из ситуации и хотелось бы разобраться как можно этого избежать.

    Спасибо.
    Миниатюры Миниатюры Нажмите на изображение для увеличения. 

Название:	рис.1.png 
Просмотров:	102 
Размер:	20.4 Кб 
ID:	38157   Нажмите на изображение для увеличения. 

Название:	рис.2.png 
Просмотров:	104 
Размер:	10.3 Кб 
ID:	38158  

  2. #2
    Пользователь
    Регистрация
    09.10.2014
    Адрес
    Киров
    Сообщений
    686

    По умолчанию

    Вместо АС4 резистор на 120 Ом воткните (если витая пара конечно)

  3. #3

    По умолчанию

    Возможно у АС4 линии A и B через резисторы подключены к +5 В.

  4. #4

    По умолчанию

    Просто резистор вместо АС4 не помогает, а вот по поводу подключения А и В к +5В похоже ближе к правде.

  5. #5

    По умолчанию

    Цитата Сообщение от igkondrat Посмотреть сообщение
    Просто резистор вместо АС4 не помогает
    100 Ом вместо АС4 пробовали вешать ?

  6. #6

    По умолчанию

    У меня 120 Ом, я думаю 20 Ом не большая разница?

  7. #7

    По умолчанию

    Цитата Сообщение от igkondrat Посмотреть сообщение
    У меня 120 Ом, я думаю 20 Ом не большая разница?
    В наших делах мелочей не бывает.

  8. #8

    По умолчанию

    Была подобная проблема. В одном шкафу стояло несколько модулей Мx110+СПК107, в другом шкафу стояли 2 частотника и 2 модуля. Проблема была в том, что связь между шкафами была очень нестабильной. Также заметил, что когда во втором шкафу на линии висит АС4 подключенный к USB - всё становилось ОК. Проблема решилась следующим образом: где-то на форуме вычитал, что все модули в сети должны сидеть на одном питании, а у меня один шкаф был подключен через трансформатор и ИБП, а второй - просто фаза и ноль. Когда завёл на все модули одно и то же питание - все сбои связи прекртатились.

Похожие темы

  1. конвейерная линия
    от moldran в разделе Подбор Оборудования
    Ответов: 2
    Последнее сообщение: 17.03.2015, 12:05
  2. технологическая линия
    от rovki в разделе Подбор Оборудования
    Ответов: 12
    Последнее сообщение: 02.09.2010, 15:52
  3. овен Opc-rs485 в режиме Spy
    от Юрий_Уфа в разделе Master SCADA 3
    Ответов: 1
    Последнее сообщение: 05.04.2010, 12:50
  4. ОВЕН ОРС RS485 по протоколу ОВЕН
    от Андрей Р в разделе Эксплуатация
    Ответов: 4
    Последнее сообщение: 11.04.2008, 06:23
  5. Линия RS-485 где + а где -
    от незарегистрированный в разделе Помощь Разработчикам
    Ответов: 2
    Последнее сообщение: 24.01.2008, 15:22

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •