Страница 5 из 5 ПерваяПервая ... 345
Показано с 41 по 45 из 45

Тема: ПЛК110 М02 и 485-2

  1. #41

    По умолчанию

    Цитата Сообщение от SuP Посмотреть сообщение
    Добрый день!

    Были ли замечены проблемы с ModBus RTU на RS-485 на прошивке v.1.0.11_plc110_m02 ?

    У меня была ошибка 81 по порту, простой откат на прошивку 1.0.6 исправил ситуацию (но подробностей не смогу дать, так как всё делалось срочно, экспериментов никаких не сделал).

    Допускаю, что я сам был где-то невнимателен, и с прошивкой v.1.0.11_plc110_m02 тоже всё в порядке, но хотел бы уточнить.
    Добрый день.
    Действительно, RS-485 более стабильно работает на прошивке 1.0.6. Продолжайте работать на ней.
    Инженер группы технической поддержки компании "ОВЕН"

  2. #42

    По умолчанию

    Понял, спасибо!

  3. #43

    По умолчанию

    Добрый день.
    Действительно, RS-485 более стабильно работает на прошивке 1.0.6. Продолжайте работать на ней.
    Есть планы выпустить нормальную прошивку?

  4. #44
    Пользователь
    Регистрация
    05.05.2015
    Адрес
    Уфа
    Сообщений
    15

    Lightbulb

    Похожая проблема.
    1) Имеется ПЛК110-30[М02], прошивка заводская версии 1.0.11.
    На порту RS-485-2 "сидит" 2 аналоговых модуля МВ110-24.8АС с slave-адресами 21 и 22.
    Когда модули опрашиваются по-отдельности (например, опрашиваем 21 при отключенном 22 и наоборот), каждый из них отвечает нормально.
    Но стоит подключить оба модуля одновременно, как один из них перестает отвечать (ошибка 81).

    2) В другом проекте с таким же ПЛК была такая же ситуация при опросе расходомеров Взлет ЭМ по Modbus RTU (порт ПЛК RS232 через преобразователь RS232-RS485).
    Когда оба расходомера были подключены, один из них не отвечал (ошибка 81). Slave-адреса разные. По отдельности отвечали корректно. Ранее несколько лет назад подключал точно такие же расходомеры к такому же ПЛК - все работало.

    Проект по п.1 прикрепляю.
    Может ли это быть связано с версией прошивки ПЛК (версия 1.0.11 - не рабочая)?
    Какая версия прошивки на сегодняшний день самая стабильная?
    Вложения Вложения

  5. #45

    По умолчанию

    Цитата Сообщение от Данис Посмотреть сообщение
    Похожая проблема.
    1) Имеется ПЛК110-30[М02], прошивка заводская версии 1.0.11.
    На порту RS-485-2 "сидит" 2 аналоговых модуля МВ110-24.8АС с slave-адресами 21 и 22.
    Когда модули опрашиваются по-отдельности (например, опрашиваем 21 при отключенном 22 и наоборот), каждый из них отвечает нормально.
    Но стоит подключить оба модуля одновременно, как один из них перестает отвечать (ошибка 81).

    2) В другом проекте с таким же ПЛК была такая же ситуация при опросе расходомеров Взлет ЭМ по Modbus RTU (порт ПЛК RS232 через преобразователь RS232-RS485).
    Когда оба расходомера были подключены, один из них не отвечал (ошибка 81). Slave-адреса разные. По отдельности отвечали корректно. Ранее несколько лет назад подключал точно такие же расходомеры к такому же ПЛК - все работало.

    Проект по п.1 прикрепляю.
    Может ли это быть связано с версией прошивки ПЛК (версия 1.0.11 - не рабочая)?
    Какая версия прошивки на сегодняшний день самая стабильная?
    Добрый день.
    Попробуйте увеличить параметр Framing time (Конфигурация ПЛК-Modbus Master - RS-485(RS-232)) до 10 мс.
    С уважением, Коськовецкий Владислав.
    Инженер группы технической поддержки компании "ОВЕН"

Страница 5 из 5 ПерваяПервая ... 345

Похожие темы

  1. Ответов: 45
    Последнее сообщение: 29.03.2017, 10:15
  2. Ответов: 11
    Последнее сообщение: 16.12.2016, 21:53
  3. Замена ПЛК110-60 [М01] на новую линейку ПЛК110-60 [М02]
    от RomanKuzmin в разделе ПЛК1хх [М02]
    Ответов: 1
    Последнее сообщение: 16.10.2016, 09:36
  4. Ответов: 15
    Последнее сообщение: 13.10.2016, 16:27
  5. Ответов: 5
    Последнее сообщение: 09.08.2016, 13:30

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •