Страница 2 из 4 ПерваяПервая 1234 ПоследняяПоследняя
Показано с 11 по 20 из 38

Тема: ПЛК304. Codesys 3.5. Проблемы при компиляции.

  1. #11

    По умолчанию

    Может версия кодесиса другая? У меня 3.5 SP5 Patch5
    Новый точечный рисунок (3).jpg
    Последний раз редактировалось arsenius; 09.02.2016 в 15:31.

  2. #12

    По умолчанию

    До версий-то я докопался. Через пень-колоду. Она в ArchivatorOwenLib и в самом деле старше, чем в модбасных. Но как поправить версию? Пока никакие манипуляции не помогают.

  3. #13

    По умолчанию

    У меня смутное подозрение что у вас включен режим упрощенной работы с библиотеками:
    свойства.png

    А также что у вас выбран режим набора свойств: Стандартный, рекомендую использовать: Профессиональный.
    Там имеется как раз кнопочка "Заданные наборы свойств..."
    Последний раз редактировалось Шевцов Игорь; 09.02.2016 в 15:51.

  4. #14

    По умолчанию

    чтобы отображать все версии библиотек и устройств Вам необходимо зайти в настройки как на скриншоте в #13 , нажать клавишу заданные наборы свойств и выбрать профессиональный.
    тогда менеджеры библиотек получат дополнительные разделы и функции из репозиториев

  5. #15

    По умолчанию

    Спасибо. С настройками разобрался. Осталось с версией Standard разобраться.

  6. #16

    По умолчанию

    Скачиваю с сайта ArchivatorOwenLib.compiled-library. Меняю расширение на .library, открываю в кодесис. Предлагают обновить версии, обновляю Standard до совпадающей с теми, что в Modbus-библиотеках. Сохраняю в формате .compiled-library и подключаю её к кодесису в репозитории. Подключаю библиотеку в проекте. В менеджере библиотек её видно, однако добавить функциональные блоки из неё не получается, а вручную их прописать - вываливаются ошибки.
    Что я делаю не так? И главное - как сделать правильно

  7. #17
    Супер Модератор Аватар для Евгений Кислов
    Регистрация
    27.01.2015
    Адрес
    Москва
    Сообщений
    7,532

    По умолчанию

    Цитата Сообщение от arsenius Посмотреть сообщение
    Скачиваю с сайта ArchivatorOwenLib.compiled-library. Меняю расширение на .library, открываю в кодесис. Предлагают обновить версии, обновляю Standard до совпадающей с теми, что в Modbus-библиотеках. Сохраняю в формате .compiled-library и подключаю её к кодесису в репозитории.
    Я не очень понял, зачем все эти манипуляции - почему просто нельзя установить в репозиторий библиотеку в формате .compiled-library?

  8. #18

    По умолчанию

    Проблема описана выше. Конфликтуют библиотеки из-за(как мне объяснили) несовместимости версий вложенных библиотек Standard. Они и в самом деле не совпадают. Вот пытаюсь привести их в соответствие самостоятельно.

  9. #19
    Супер Модератор Аватар для Евгений Кислов
    Регистрация
    27.01.2015
    Адрес
    Москва
    Сообщений
    7,532

    По умолчанию

    Цитата Сообщение от arsenius Посмотреть сообщение
    Проблема описана выше. Конфликтуют библиотеки из-за(как мне объяснили) несовместимости версий вложенных библиотек Standard. Они и в самом деле не совпадают. Вот пытаюсь привести их в соответствие самостоятельно.
    Тогда просто поменяйте версию библиотеку Standard, вставляемой в проект по умолчанию, на ту, которая входит в библиотеку архивации. Предварительно нужно включить профессиональный режим настроек (пост 13).

    1122233.png

  10. #20

    По умолчанию

    Вот узнал что-то новое Дело в том, что эту библиотеку по умолчанию я удалил почти сразу из-за конфликтов (не зная про заполнители (placeholders у меня)). И по началу всё работало, пока не понадобилась библиотека архивирования. На данный момент конфликтуют внутренние Standard библиотек ArchivatorOwenLib, Modbus и Modbus-slave. А их я через окно заполнителей поменять не могу.
    Последний раз редактировалось arsenius; 10.02.2016 в 11:05.

Страница 2 из 4 ПерваяПервая 1234 ПоследняяПоследняя

Похожие темы

  1. предупреждение при компиляции
    от Назаров Александр в разделе ПЛК1хх
    Ответов: 16
    Последнее сообщение: 31.08.2015, 13:09
  2. ПЛК304 ошибки компиляции
    от Yury Evgenev в разделе ПЛК3хх
    Ответов: 1
    Последнее сообщение: 19.07.2014, 15:41
  3. Ответов: 3
    Последнее сообщение: 14.11.2012, 09:09
  4. Проблема при компиляции
    от Солнечный заяц в разделе СПК2хх
    Ответов: 10
    Последнее сообщение: 12.11.2011, 04:33
  5. Ответов: 1
    Последнее сообщение: 15.06.2011, 14:27

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •