Показано с 1 по 5 из 5

Тема: СП 270 Потеря связи.

  1. #1

    По умолчанию СП 270 Потеря связи.

    Приветствую. На панели СП 270 вылетает ошибка Потеря связи Порт PLC адрес 1.
    Панель является мастером. Микроконтроллер STM32 является слейвом. На панели имеется элемент - цифровой дисплей, куда я хочу получить значение регистра, который имеет адрес 256 (также пробовал получить данные с адреса 1008). Для этого использую функцию 0x04. Адрес слейв устройства - 17. Слейв устройство тестировал в программе modbus poll. Всё работает. Слейв устройство подключаю на порт PLC по 485 интерфейсу (4, 7ой пин).
    Настройки Слейв и мастер устройств
    Modbus rtu - mb rtu
    38400 - 38400
    par none - none
    1 stop bit - 1 stop bit
    Не могу понять, почему нет связи

  2. #2
    Пользователь
    Регистрация
    23.09.2008
    Адрес
    Центророссийск
    Сообщений
    2,553

    По умолчанию

    ..(4, 7ой пин).
    Мож A/B местами ?
    Слейв устройство подключаю на порт PLC
    На download панели запили слейв с теми же настройками, заверни линию на себя же и пощупай связь.

  3. #3

    По умолчанию

    Подключил панель к пк, через программу terminal. Cвязь идет. Но есть одно но: В элементе - цифровой дисплей - управление - регистр я задаю команду 4x, а терминал мне показывает, что используется modbus функция 3x. Если в цифровом дисплее я ставлю 3x. То панель прошивается и после не работает. мигает каждые 3 сек
    Всё, разобрался. Тема закрыта.
    Последний раз редактировалось Cheeseman; 30.05.2020 в 13:39.

  4. #4

    По умолчанию

    Написал бы про свой косяк... может кому и пригодится...

  5. #5

    По умолчанию

    проблема была в следующем. В меню управление есть параметр регистр. И числа 0x0, 0х01, 0х03, 0х04. Сначала я подумал, что это modbus функции(хоть и удивило наличие 0x00). Устройство у меня общалось по функции 0x04. Потом нашел следующую таблицу, подредактировал код на stm для работы по другим функциям. В частности 01, 03, 05, 010 и все заработало5c06e39f2267.png
    Последний раз редактировалось Cheeseman; Сегодня в 13:42. Причина: не добавил рисунок

Похожие темы

  1. Потеря связи
    от Вова13 в разделе Сетевые технологии
    Ответов: 12
    Последнее сообщение: 06.02.2019, 00:22
  2. ПЛК - МВ потеря связи
    от werg в разделе ПЛК1хх
    Ответов: 9
    Последнее сообщение: 25.02.2018, 16:15
  3. Потеря связи RS-485
    от arsm в разделе СПК1хх
    Ответов: 5
    Последнее сообщение: 09.12.2014, 15:59
  4. Потеря связи по Ethernet с ПЛК 100
    от MCBK в разделе ПЛК1хх
    Ответов: 1
    Последнее сообщение: 14.02.2012, 09:46
  5. потеря связи плк 110-60
    от Ден в разделе ПЛК1хх
    Ответов: 22
    Последнее сообщение: 05.05.2011, 20:41

Метки этой темы

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •