Страница 317 из 322 ПерваяПервая ... 217267307315316317318319 ... ПоследняяПоследняя
Показано с 3,161 по 3,170 из 3217

Тема: CODESYS V3.5. Вопросы и ответы

  1. #3161

    По умолчанию

    Не пойму, что не нравится компилятору?
    Пишет: C0037: 'eState' не является входом 'PLC_PRG'
    Ведь другие переменные видит...
    Объявление в PLC_PRG:
    Screenshot_1.jpg
    В коде вызываемой функции:
    Screenshot_2.jpg

  2. #3162

  3. #3163

    По умолчанию

    Ясно. Спасибо!

  4. #3164

    По умолчанию

    Разбираемся дальше..Проект огромный у меня и притом первый ..но делать нужно за нами Москва...
    Итак есть потребность в ПИД регуляторе ( управление чиллером ) я так понимаю что торопится с ним не стоит и поэтому ну думаю время для ПИД выставить ...хотя бы 1 мин ( 60 сек)
    входной параметр - температура,пусть будет 5-30гр.Цельсия ,выходной - производительность чиллера в процентах...
    подсмотрел в Библиотеке UTIL.Library есть PID и PID_FIXCYCLE ..прошу помощи...подойдут ли данные регуляторы для моей задачи или поискать что то еще...или может кто что посоветует?( если готовы помочь не только словом но и делом не откажусь от помощи за оплату)

  5. #3165

    По умолчанию

    Добрый день.
    Подскажите, где можно найти target - file для ПЛК Berghoff EC100?!
    ПЛК взят с неработающей установки - решили использовать его в других целях, а target file нигде не могу найти(

  6. #3166
    Супер Модератор Аватар для Евгений Кислов
    Регистрация
    27.01.2015
    Адрес
    Москва
    Сообщений
    6,810

    По умолчанию

    Цитата Сообщение от forfiftyone Посмотреть сообщение
    Добрый день.
    Подскажите, где можно найти target - file для ПЛК Berghoff EC100?!
    ПЛК взят с неработающей установки - решили использовать его в других целях, а target file нигде не могу найти(
    Добрый день.
    Напишите в Пролог - они являются российскими партнерами Berghof.
    info@prolog-plc.ru

    http://www.prolog-plc.ru/partners

    Я в свое время именно у них запрашивал и таргет, и прошивку для EC1000.

  7. #3167

    По умолчанию

    Добрый день.
    Где почитать про библиотеки, зависимости. Как допустим поменять более старую библиотеку в проекте на более новую. Вот скриншот пытаюсь установить MQTT client. Codesys.png

  8. #3168
    Супер Модератор Аватар для Евгений Кислов
    Регистрация
    27.01.2015
    Адрес
    Москва
    Сообщений
    6,810

    По умолчанию

    Цитата Сообщение от geotime Посмотреть сообщение
    Добрый день.
    Где почитать про библиотеки, зависимости. Как допустим поменять более старую библиотеку в проекте на более новую. Вот скриншот пытаюсь установить MQTT client. Codesys.png
    Добрый день.
    Какую версию CODESYS вы используете?

  9. #3169

    По умолчанию

    Добрый день.
    Установлен CDS 3.5 SP 14. patch 3 для ПЛК 210. Новая библиотека https://github.com/stefandreyer/CODESYS-MQTT MQTT 1.2.0.5.library использует версию CDS 3.5 SP 16. patch 3 и ее у меня не получается поставить, из-за того что версия системных библиотек меньше. Скачал версию 3.5.11 (более старую для CDS 3.5 SP 13. ) не могу поставить ругается как на скриншоте выше. Хотел для себя прояснить можно ли как-то в проекте поменять/заменить версию библиотеки? Допустим проект ссылается на версию CAAFile 3.5.13.0 , точно такой в системе нет, но есть более свежая 3.5.13.40 как указать в проекте использовать более свежую (понятно что ФБ (название, методы и т.д) в новой должны совпадать с предыдущей. И что делать в обратной ситуации когда версия библиотеки в проекте выше чем установлено в IDE. Прошу помочь разобраться в этом вопросе. С уважением Юрий.

    P.S. Или поставить 3.5.SP16 и из него попробовать сохранить в предыдущую версию?
    Последний раз редактировалось geotime; 18.05.2021 в 03:23. Причина: Уточнения

  10. #3170
    Супер Модератор Аватар для Евгений Кислов
    Регистрация
    27.01.2015
    Адрес
    Москва
    Сообщений
    6,810

    По умолчанию

    1. Если в проекте используется библиотека более младшей версии (по сравнению с версией таргета) - то должна была быть кнопка Загрузка отсутствующих библиотек.
    2. Если в проекте используется библиотека более старшей версии (по сравнению с версией таргета) - то должна была быть кнопка Плейсхолдеры для выбора конкретной версии.

    У вас почему-то нет ни одной из этих кнопок.
    Чтобы дать какие-то комментарии - нужен доступ по TeamViewer.

Страница 317 из 322 ПерваяПервая ... 217267307315316317318319 ... ПоследняяПоследняя

Похожие темы

  1. Панели оператора СП3xx. Вопросы и ответы
    от Мурат Ахриев в разделе Панели оператора (HMI)
    Ответов: 2104
    Последнее сообщение: 12.06.2021, 22:03
  2. Панели оператора ИП320. Вопросы и ответы
    от automat в разделе Панели оператора (HMI)
    Ответов: 627
    Последнее сообщение: 01.06.2021, 19:16
  3. ИПП120. Вопросы и ответы
    от Р.Александр в разделе Программируемые реле
    Ответов: 218
    Последнее сообщение: 25.05.2021, 19:55
  4. Индикатор ИП120 , вопросы- ответы
    от rovki в разделе Программируемые реле
    Ответов: 56
    Последнее сообщение: 03.11.2017, 15:58
  5. Панели оператора СП270. Вопросы и ответы
    от Давидюк в разделе Панели оператора (HMI)
    Ответов: 930
    Последнее сообщение: 15.05.2017, 17:12

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •