Страница 1 из 2 12 ПоследняяПоследняя
Показано с 1 по 10 из 12

Тема: Пропадание связи по ModBus

  1. #1

    По умолчанию Пропадание связи по ModBus

    Здравствуйте. В котельной эксплуатируется ПЛК-100, который опрашивает МВА8 по ModBus. Периодически (раз в несколько месяцев) связь теряется. Помогает перезагрузка ПЛК. Возможно-ли возобновить обмен программно без перезагрузки ПЛК? На форуме ответа не нашел.
    Программу прилагаю.
    Вложения Вложения

  2. #2

    По умолчанию

    А какой у Вас котел ?

  3. #3
    Пользователь
    Регистрация
    11.01.2009
    Адрес
    Кострома
    Сообщений
    3,249

    По умолчанию

    потерю связи можно отследить(ошибка 81).
    При этом вводите к примеру ПЛК в бесконечный цикл.
    ПЛК перезагрузится.
    Почему у Вас возникает такая ситуация наверное никто не скажет.

  4. #4

    По умолчанию

    Цитата Сообщение от Newcomer Посмотреть сообщение
    А какой у Вас котел ?
    Котел КВ-Г-1,25-95

  5. #5

    По умолчанию

    Цитата Сообщение от lara197a Посмотреть сообщение
    потерю связи можно отследить(ошибка 81).
    При этом вводите к примеру ПЛК в бесконечный цикл.
    ПЛК перезагрузится.
    Почему у Вас возникает такая ситуация наверное никто не скажет.
    Как отследить это понятно. Вопрос возможно ли перезапустить обмен по ModBus без перезагрузки контроллера.
    Перезагрузка ПЛК приводит к остановке котла.

  6. #6
    Пользователь
    Регистрация
    23.09.2008
    Адрес
    Центророссийск
    Сообщений
    2,553

    По умолчанию

    Штатно - нет.

  7. #7
    Пользователь
    Регистрация
    11.01.2009
    Адрес
    Кострома
    Сообщений
    3,249

    По умолчанию

    Выставляйте перед перезагрузкой какой нибудь энергонезависимый флаг(маркер).
    После перезагрузки при наличии его перезапускайте котел и сбрасывайте флаг.
    Или пробовать менять железо.
    Так же рекомендовал бы увеличить цикл ПЛК и время опроса.

  8. #8

    По умолчанию

    А попробуйте при таких зависаниях перезагрузить модуль МВА8. Если поможет, то тогда перезапускайте его. Можно перейти на modbus.lib она в отличии от встроенного modbus master (того что настраивается в plc конфигураторе) работает стабильно.
    ps Так же можете попробовать увеличить таймаут чтения.

  9. #9

    По умолчанию

    Цитата Сообщение от lara197a Посмотреть сообщение
    Выставляйте перед перезагрузкой какой нибудь энергонезависимый флаг(маркер).
    После перезагрузки при наличии его перезапускайте котел и сбрасывайте флаг.
    Или пробовать менять железо.
    Так же рекомендовал бы увеличить цикл ПЛК и время опроса.
    Совет дельный только котел не желательно презапускать.

  10. #10
    Пользователь
    Регистрация
    11.01.2009
    Адрес
    Кострома
    Сообщений
    3,249

    По умолчанию

    Вам бы конечно надо бы разобраться с причиной.
    Если виснет порт ПЛК, то фиксированный цикл к примеру в 20мс проблему решит.
    Для котла это даже очень быстро. У них цикл в 100мс- это нормально. Там нет быстрых процессов.

    Если виснет МВА, то или поменять или перегружать. Если, как Вы пишете, это происходит крайне редко, то вполне допустимо и перезапустить котел.

Страница 1 из 2 12 ПоследняяПоследняя

Похожие темы

  1. Потеря связи по ModBus сразу со всеми приборами
    от Aleksandr_Sorokin в разделе Сетевые технологии
    Ответов: 2
    Последнее сообщение: 02.10.2013, 22:57
  2. [ПЛК] Наличие связи по Modbus
    от Frayl в разделе ПЛК1хх
    Ответов: 8
    Последнее сообщение: 16.10.2012, 16:54
  3. МДВВ нет связи по MODBUS
    от serega_nf в разделе Сетевые технологии
    Ответов: 14
    Последнее сообщение: 23.10.2011, 10:35
  4. проблемы связи по Modbus
    от IvanM в разделе Панели оператора (HMI)
    Ответов: 38
    Последнее сообщение: 14.12.2010, 14:16

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •