Страница 1 из 3 123 ПоследняяПоследняя
Показано с 1 по 10 из 23

Тема: Проблеммы с ЕКОН134

  1. #1

    По умолчанию Проблеммы с ЕКОН134

    Здравствуйте.
    Не так давно наш завод приобрёл приборы ЕКОН134 для реализации текущего проекта автоматизации.
    Сейчас в сети работают два прибора ЕКОН134; используется у них пока только порт P1; опрос ведётся с помощью LECTUS OPC SERVER. Опрашиваются 5 приборов МВ110-16Д на первом преобразователе и 6 на втором по линии RS-485. Общая протяженность линии RS-485 на каждом порту не более 500м.

    Так вот, при работе с приборами возникли две основные проблемы:

    1) Нестабильная связь с приборами на линии RS-485. Сначала пробовал связь на скорости 57600. В результате, с периодичностью примерно в минуту или даже чаще, происходила потеря связи то с одним, то с другим прибором МВ110-16Д, через секунд 5-6 связь восстанавливалась. Потом снизил скорость до 9600 - связь стала лучше, но всё равно время от времени пропадает. Сразу хочу отметить, что вся линия до приборов проведена экранированной витой парой и общая длина не превышает 500м, так что на качество линии тут сослаться нельзя, и связь по сети тоже хорошая и быстрая (проверялось командой ping прямо во время пропадания связи с приборами МВ110-16Д).
    Тем более что в другом проекте при связи через АС3-М, при длине линии близкой к пороговой (1100м) и проведённой обычным телефонным кабелем, подобных сбоев не было ни разу.

    2) Если с первой проблемой худо бедно удалось справиться путём понижения скорости связи до 9600, то что делать со второй проблемой теряюсь в догадках. А состоит она в том, что ваш прибор ЕКОН134 стабильно, минимум раз в сутки намертво виснет. Сетевая связь с ним пропадает полностью - в конфигураторе он горит красным и не опрашивается командой ping, хотя на самом приборе все индикаторы горят зелёным. Помогает только кнопка перезагрузки или отключение/включение питания.

    Опрос приборов ЕКОН134 производиться с одного компьютера, связь с портами "без запроса" (с запросом происходит тоже самое). Пробовал менять кучу настроек как в конфигураторе виртуальных портов, так и на OPC сервере - разницы не заметил.

    Прошу решить данные проблемы или написать рекомендации, если подобные случаи уже наблюдались. Заранее спасибо.

  2. #2
    Пользователь Аватар для evgeha
    Регистрация
    26.03.2009
    Адрес
    Ярославль
    Сообщений
    129

    По умолчанию

    У нас на предприятие были аналогичные проблемы, притом еще и связь по RS485 более 300 м не устанавливал. (хотя обычный АС-4 с этой задачей справлялся на ура) по изернету он был подключен у самого компьютера, устанавливали с целью диспетчеризации, и так-же терял связь, помогало только обесточивание прибора. Так мы ничего решить и не смогли, на форуме ничего внятного не ответили. в итоге прибор валяется на складе поставили АС-4

  3. #3

    По умолчанию

    У нас возможности перейти на обычную линию 485 на большое расстояние нет, поэтому и решили применить эти приборы для связи по изернету. На днях ответили из тех поддержки, сказали, что действительно такие проблемы у этих приборов есть, обещали исправить через месяца 3 в следующей версии.
    Что тут сказать, приборы уже куплены, придётся ждать. Но пока, на текущие проекты, наверное, придётся переходить на MOXу.

  4. #4

    По умолчанию

    Соединил ЕКОН134 и ПЛК63 по RS232. При загрузке программы в контроллер через Codesys 2.3 сама загрузка проходит устешно, но диалог, информирующий о загрузке, не исчезает, и соединение отваливается по таймауту. Пробовал играть таймаутами порта и в секции project-options-desktop, ничего не помогло. Не подскажет кто-нибудь что где подкрутить, чтобы избавиться от этой проблемы?

    PS: кстати, через Defender-овский USB-RS232 все работает замечательно, как ни странно.

  5. #5

    По умолчанию

    agz
    При конфигурировании екон134 в программе " конфигуратор виртуальных портов" в настройках необходимого порта поставьте режим обмена данными "без запроса" и IP-адрес назначения необходимо выставить аналогичным локальному адресу указанному в сетевых настройках.

  6. #6

    По умолчанию

    Цитата Сообщение от G.Mark Посмотреть сообщение
    agz
    При конфигурировании екон134 в программе " конфигуратор виртуальных портов" в настройках необходимого порта поставьте режим обмена данными "без запроса"
    благодарю, помогло.

  7. #7

    По умолчанию

    К P1=RS485 подключен Овен OPC-сервер для приборов Modbus, через P2=RS232 логинится Codesys к ПЛК63. В такой конфигурации ЕКОН134 постоянно подвисает, лечится передергиванием питания на нем. Если используется только порт P1, то вроде как не зависает (тест сутки).

  8. #8

    По умолчанию

    ЕКОН134 виснет даже с использованием одного порта. Вис в течение недели. Бывало продержится дня два, но это максимум.
    Сейчас сделали перезагрузку ЕКОНу каждый день с помощью таймера реального времени УТ1 - вроде как работает. Но всё же хочется, чтобы поскорее исправили этот глюк.
    Насчёт настройки приборов через связь по ЕКОНу. Пытался переконфигурировать МВ110-16D, как то не вышло. При попытке конфигуратора МВ110 связаться с прибором МВ110-16D, сразу пропадала связь в конфигураторе виртуальных портов с ЕКОНом. Порт был настроен "без запроса". Может, что не так делал, не знаю, но пришлось подключаться к МВ110-16D напрямую через АС3-М.

  9. #9

    По умолчанию

    5-ый месяц уже проблема с зависанием ЕКОН134 v1.11 не решена... когда наконец выйдет исправная прошивка?

    PS: вопрос к разработчикам.
    Последний раз редактировалось agz; 12.08.2013 в 12:46.

  10. #10

    По умолчанию

    есть анологичная проблема

Страница 1 из 3 123 ПоследняяПоследняя

Похожие темы

  1. ЕКОН134 + АС-2М
    от mehfk в разделе Сетевые технологии
    Ответов: 9
    Последнее сообщение: 05.07.2013, 15:56
  2. АС-2М+ЕКОН134+OPM
    от mehfk в разделе OWEN Proces Manager
    Ответов: 2
    Последнее сообщение: 13.09.2012, 19:51
  3. САУ - проблеммы при эксплуатации.
    от P@r@zit в разделе Эксплуатация
    Ответов: 1
    Последнее сообщение: 14.12.2011, 08:58
  4. Ответов: 9
    Последнее сообщение: 07.09.2010, 18:42
  5. проблеммы с контроллером Owen110
    от SvAlex в разделе ПЛК1хх
    Ответов: 10
    Последнее сообщение: 07.07.2010, 18:51

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •