Показано с 1 по 6 из 6

Тема: ethernet и плк

  1. #1

    По умолчанию ethernet и плк

    Здравствуйте, помогите настроить плк для связи по ethernet cо Scada системой. Имеется контроллер plc 150, подключаю к компьютеру с MasterScada, настраиваю ip, opc сервер, добавляю в скаду: работает. Плк должен стоять в цехе, а скада в диспетчерской, ставим плк на рабочее место: связи нет, ping адреса не идет. Связь идет через пассивные концентраторы. Почему напрямую связь есть, с hubом нет? Спасибо.

  2. #2

    По умолчанию

    Отличный вопрос А почему Вы задаете его нам, а не своим системным администраторам?
    Если серьезно - проверьте, чтобы MAC адрес ПЛК начинался с четного числа.
    Попробуйте поиграть со скоростью связи между контроллером и ПК (такие настройки есть в OPC сервере и в CoDeSys).

    Ну и подумайте над выделением данной линии связи в отдельную подсеть, тем более если у Вас большая локалка.

  3. #3

    По умолчанию

    Возможно кабель не правильный используете.
    Если связь PC-PLC то ту используется пачкорд кроссовер. Если же не на прямую, а через сетевые коммуникаторы, то обычные пачкорды.

  4. #4
    Пользователь
    Регистрация
    11.01.2009
    Адрес
    Кострома
    Сообщений
    3,246

    По умолчанию

    Вы действительно к садмину подойдите. Скорее всего у них на сервере свой диапазон IP.
    Используйте OPC CoDeSys. Стабильно работает в сетях с огромной периферией, на больших удалениях. Проверено.

  5. #5

    По умолчанию

    Попробуйте в цеху подключить ноут, если есть возможность, и попинговать его, чтобы наверняка выявить проблемное звено.
    Железяка должна быть такой: нажал кнопку — работает

  6. #6

    По умолчанию

    Цитата Сообщение от alex2010k Посмотреть сообщение
    Здравствуйте, помогите настроить плк для связи по ethernet cо Scada системой. Имеется контроллер plc 150, подключаю к компьютеру с MasterScada, настраиваю ip, opc сервер, добавляю в скаду: работает. Плк должен стоять в цехе, а скада в диспетчерской, ставим плк на рабочее место: связи нет, ping адреса не идет. Связь идет через пассивные концентраторы. Почему напрямую связь есть, с hubом нет? Спасибо.
    не знаю.
    мы такую лабуду тоже замутили и у нас всё работает.
    запросили у админов свободный IP и поменяли заводской IP в ПЛК на тот который дали админы( ну например 192.168.8.220 и маску 255.255.252) и всё. дальше всё по инструкции.

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •