Показано с 1 по 5 из 5

Тема: При добавлении в конфигурацию ПЛК панели ИП320 не записываются данные в регистр

  1. #1

    Question При добавлении в конфигурацию ПЛК панели ИП320 не записываются данные в регистр

    Здравствуйте.
    Сложилась такая проблема: имеется ПЛК100К.М (Master), target v2.10, модуль МВ110-8АС, и панель ИП 320 (slave), сеть RS-485 (ModBus RTU), скорость 11520.
    К МВ110 подключен температурный датчик.
    Измеренное значение температуры отображается на панели (регистр 4х18), кроме того имеется список из 6 аварий (биты 0х0...0х6). Программа ПЛК проста до безобразия - измеренное значение температуры передается в регистр для отображении на панели, и вроде бы все работает, НО:
    1. Отображается только температура. Аварии не работают (см. скрин №1).
    Если поменять местами 8 bit output module (аварии) и register output module (температура), то начинают работать аварии и перестает отображаться температура (скрин №2).
    Если удалить конфигурацию МВ110, то работают и ошибки, и температура (скрин №3).

    т.е. работает только первый из регистров (который выше в конфигурации ПЛК).
    Если кто знает в чем дело - подскажите как это исправить.
    Изображения Изображения

  2. #2

    По умолчанию

    Аварии в ИП должны начинаться с 0 бита ОБЯЗАТЕЛЬНО. Поэтому ситуация скрин1.
    Добавлять элементы 8bits можно и нужно только парами (2 элемента 8bits - 1 регистр). Иначе сбивается адресация регистров, поэтому ситуация скрин 3.

  3. #3

    По умолчанию

    Цитата Сообщение от Viktor UMC Посмотреть сообщение
    Аварии в ИП должны начинаться с 0 бита ОБЯЗАТЕЛЬНО. Поэтому ситуация скрин1.
    Добавлять элементы 8bits можно и нужно только парами (2 элемента 8bits - 1 регистр). Иначе сбивается адресация регистров, поэтому ситуация скрин 3.
    Спасибо за ответ. Но тут же второй вопрос: а почему при удалении конфигурации МВ110 все начинает работать?

  4. #4
    Пользователь
    Регистрация
    23.09.2008
    Адрес
    Центророссийск
    Сообщений
    2,543

    По умолчанию

    А вы оба проекта выложьте. Тогда и помогут. Местные врачи по фоткам не лечат.

  5. #5

    По умолчанию

    Есть еще мнение, что проблема лечится уменьшением скорости опроса. До 38400 например. Сама конфигурация правильная, должно работать.

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •